Morph

From Dragon Age Toolset Wiki

Jump to: navigation, search
Creature topics:
The new resource menu contains a "Morph" option

Morphs are highly customizable heads that can be added to many of the common humanoid creatures in Dragon Age to create unique characters. They are not listed on the palette window; to create a new morph you'll have to go to the "File" menu, select "New", and then select "Morph" from the list of resource types.

A morph must first start with a basic head shape. Select one from the drop-down menu in the toolbar (it defaults to "choose base", indicating the need to select one) and the head will appear in the main display. The camera can be maneuvered around it using many of the same basic controls used elsewhere in the toolset. The head bases that are available include male and female versions of Human, Dwarf, Elf, and a gender-neutral child's head.

Once the base is selected, an enormous number of options will become available in the object inspector for modifying the exact shape and texture of the head. Hairstyles and beards can be added, tattoo textures can be overlaid on the skin, and so forth - there are hundreds of parameters.

To speed the creation of unique generic NPCs, the "randomize" button in the toolbar will set the various shape parameters to random values. This doesn't affect all facial features, however, since many of the adjustable features would look quite bizarre when set to extreme values. Generally the effects of the randomize button are limited to tabs 4 through 8, and it doesn't affect all of the features even on those. Manual customization may still be required to produce a truly diverse crop of NPCs.

Note that for some features (for example, lip color) the opacity defaults to 0%, so you may not see an immediate effect when changing them unless you set the opacity higher first.

Morph editor.png

Contents

How to override companion & NPC Morphs

1. Open toolset

2. File --> Manage Modules --> Switch to single player campaign

3. Open the "Creatures" palette and put the name of the companion or npc in the filter. Example: "alistair"

4. A few tabs open up.... Expand the "_Global/Followers" folder and you will see alistair's model, (i also included npc example):

companion:
gen00fl_alistair (Alistair)
npc: 
ntb100cr_gheyna (Gheyna)

5. For companions REMOVE THE NUMBERS. For NPCs REMOVE the letters between the number and the _ ... Compare these to the ones in step 4:

companion:
genfl_alistair
npc: 
ntb100_gheyna.mor

6. Then add the appropriate prefix.

ef_         = elf female
hm_         = human male
hf_         = human female
em_         = elf male
dm_         = dwarf male
df_         = dwarf female

7. So you would rename your morph:

companion:
hm_genfl_alistair.mor   
npc:
ef_ntb100_gheyna.mor

8. Then place it into the folder:

\Documents\BioWare\Dragon Age\modules\Single Player\override

Examples:

Alistair: hm_genfl_alistair.mor
Morrigan: hf_genfl_morrigan.mor
Gheyna: ef_ntb100_gheyna.mor

If you wish to override morphs in BioWare's DLC, you can find a list of morph names here: DLC morph names. You can download the source files for the head morphs in the main campaign from here: [1].

Beards and facial features

There are two basic types of beards available for facial morphs; model beards and stubble beards. Stubble beards are simply a texture overlay, and have no particular special effects associated with them. Model beards are three-dimensional objects that are affixed to the face, and it is important to be aware of certain limitations that come with using them.

In order to make a physical beard model fit properly onto the face, some facial features must be set to their default values. This is so that, as an example, one doesn't wind up with the tip of the chin poking out through the end of the beard. When you add a physical beard model to a head morph these specific facial features are automatically snapped to their default values and are locked there for as long as the beard is in place. If the beard is removed they become editable again, but it is important to note that they do not return to whatever values they had before the beard was added. So make the decision on whether a character has a physical beard before you spend a lot of time adjusting his jawline and other such details.

Debug features

There are a number of features with "debug" in their names that are intended only to allow a facial artist to get a better view of certain parts of a facial morph, and if they are set to anything other than zero the morph won't be usable by the rest of the toolset. The most obvious example is the "teeth debug" parameter, which pulls the lips back to expose the model's teeth so that they can be adjusted in plain view.

How to use a morph in your module

Morph is an art tool, not a design tool, and so it uses a somewhat different mechanism for making its output available to the designer than the other tools that come with the toolset. You can save a morph as a file in your regular filesystem but when you go to select a head morph in the creature designer you won't be able to import directly from the filesystem to use it.

Instead, you need to export the morph via the "post to local" command under the "Tools"->"Export" menu (alternately, right-click on the morph's display window and select "post to local" from the menu). Once the morph has been exported, it will be available in the creature creator's morph list when the appropriate body appearance model is selected (eg, a human female head morph is usable with a human female body appearance). For Example, if your Filename was "Sarah" and your Base Model was Human Female the Name in the List will be "hf_Sarah". You can find the prefix name at the beginning of the base Model Name.

If you want to make a slight variation on an existing morph (say for example to change the hair colour or add a scar), load the mrh file of the desired morph, and then 'save as' with a new file name. Make your changes and save, then once again export to local. To make the new variant available, use "View"->"Refresh".

How to replace the morph of an in game NPC (Single Player Campaign)

1. Open Toolset

2. Click the "Creatures" Button on the top right Palette Window

3. In the filter type the name of the NPC, example Bella or Desire or Murdock.

4. You'll see some folders appear. Navigate through them and find the NPC object:

Example: ntb100cr_gheyna (Gheyna)

5. Now left click that creature to highlight it.

6. On the bottom right the object inspector window appears full of information.

7. Scroll down the list until you see head morph, under appearance. Note the name of that file.

8. Rename the new morph file you exported to the name in the object inspector.

9. Now place your new morph in the following directory:

documents/bioware/dragon age/packages/core/override

Make sure you restart dragon age.

Morph files

There are actually two files for every morph.

To get the *.mor file you need to use the "export" command.

To edit an existing .mrh, you can either drag and drop the .mrh into the toolset or open the *.mrh from the toolset.


The head morph tool concatenates the two letter prefix (HM for human male, HF for human female, etc.) to the filename for you. If you saved a resource called "myhead", for example, and it was a human male then it would export a hm_myhead.mor. If it was a female dwarf it would save it as df_myhead.mor

The drop down for the head morph will also auto generate the two letter prefix based on the gender and appearance of the creature you are making.

Deleting a morph

Morphs are an art asset, and as such are not stored in the database in the same manner as other resources. You can find morph files (.mor extension) in the \Dragon Age\packages\core\override\toolsetexport directory, to remove one simply delete it.

Parameters

  • Keep in mind that when selecting colors, you can open up a dropdown list where you browse for colors, and choose "All Tint Files *.tnt" to get a much wider range of color choices. The Tattoo colors especially (t1_tat_*) are very vibrant, and can give you 'very blue eyes', for example.

Choose Base model name:

01. MATERIAL:

01. Face:

02. Skin Texture:

03. Skin Type:

02. PART SELECTION:

1. Model: (Base model Chosen when starting.)

2. Parts:

3. Tattoo:

4. Brow and Stubble:

5. Crew Cut Selection:

03. FEATURE SELECTION:

01. Shape:

02. Nose:

03. Eye Shape:

04. Universal Shapes:

Reset

04. NOSE:

01. Targets:

02. Shape:

Reset

05. MOUTH:

01. Targets:

Reset

06. EYES:

01. Targets:

02. Debug

Debug Cornea Larger/Smaller: -1.00 - 1.00

Reset

07. CHEEKS:

01. Targets:

Reset

08. JAW:

01. Targets:

Reset

10. TEETH:

01. Targets:

02. Debug:

Reset

11. EARS:

01. Targets:

02. Debug:

Ears Debug for Hair Crashing: 0.00 - 1.00

Reset

12. NECK:

01. Targets:

Reset

13. BROWS:

01. Targets:

Reset

13. VIEW SETTINGS:

1. Light:

2. Camera:

3. Object:

4. Facial Animation:

14. EXPORT SETTINGS

General:

Export .mop file: True/False (False default)

14. UNIQUE SHAPES:

01. Targets:

Reset

Tints and hairstyles

Tints and hairstyles often have somewhat uninformative names. The following thumbnails provide a preview summary of what these tints and hairstyles represent:

Dwarf male beards

Human female hairstyles

hf_har_mora_0 - Morrigan's hairstyle

Human male beards

Human male hairstyles

Eye shadow

Lip colour

Skin tone

Eye colour

Hair colour

Blush colour

Tattoos

Tint file Colour
t1_tat_blk Black
t1_tat_dgn Dark Green
t1_tat_org Orange
t1_tat_blu Blue
t1_tat_dpu Dark Purple
t1_tat_pnk Pink
t1_tat_brn Brown
t1_tat_drd Dark Red
t1_tat_pur Purple
t1_tat_dbl Dark Blue
t1_tat_grn Green
t1_tat_red Red
t1_tat_dbr Dark Brown
t1_tat_gry Grey
t1_tat_yel Yellow

You can use a different colour for each Tattoo layer.

You can combine (layer) Tattoos 1 to 4 for each Tattoo mask if desired.

Sliders 0.00 to 1.00 determines darkness of the Tattoo.

All screen shots set at 1.00, black colour

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox