Compatible Companion Mod Creation

From Dragon Age Toolset Wiki

Jump to: navigation, search

The purpose of this tutorial is to help the community tackle one of the most important problems we face: compatibility between all our mods, in particular those mods that introduce custom companions.

I'll share with you my approach to handling companions, based on my experiments and experience. My goal has always been to be the least intrusive to the game core resources (meaning don't change them at all), while having the companion behave appropriately in most parts of the game.

What I'll talk about here works for Patch 1.02, but after many months of testing, it seems to be working fine also for those with Awakening, Ultimate Edition and/or even Patch 1.03, 1.04. The issue with Awakening is that BioWare has apparently changed the role of /<uid>/module/override (this is what our tests showed). So all scripts should be dumped in /<uid>/core/override to ensure everything runs smoothly. I do not recommend dumping stuff into /packages/core/override, other than new models, morphs etc. Anything in here (like scripts, gda etc), WILL destroy your game and other mods if you're not careful. I never touch that directory.

Everything in this tutorial is done WITHOUT changing game resources.

Table of Contents

The tutorial contains the following steps:

Icon wiki arrow left disabled.png Icon wiki home disabled.png Game Mechanics And Module Events
Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox